2
Cannot Set Allocation Error On Launch
Problem reported by Daniel - January 6, 2016 at 12:34 PM
Submitted
I installed Localizer GUI on a surface 3 tablet running windows 10. It installs fine, installed as an administrator. On launch, the program throws a Windows "cannot set allocations" message every time. The program GUI shows no sat data and i get the same error when I try and choose a COM port.

5 Replies

Reply to Thread
0
Lars-Bo Replied
March 15, 2016 at 11:16 AM
I also have the same problem.
 
I installed Localizer GUI on a Lenovo Thinkpad 10 tablet (20E3), which has a build-in GNSS sensor. I originally installed Localizer on a newly upgraded Windows 10 (upgraded from Windows 7) and it worked fine. But after installing all Windows 10 updates from Microsoft, Localizer reports "Cannot set allocations". Localizer was installed as administrator and I run the program as administrator. I also have tried to run it with Windows 8 or 7 compatibility with no success. Operating system is Windows 10 Pro 64 bit. Device manager tells that the sensor is a Sierra Wireless GNss Sensor EM7345. Have also updated device driver to version 15.12.10223.1 from Microsoft. "Microsoft maps" works fine with the sensor.
 
0
Matthew Replied
June 7, 2016 at 5:54 AM
I have the exact same "cannot set allocations" error when I launch the Localizer GUI on my surface 3 LTE, even though the non-GUI service works fine.  Through much troubleshooting and frustration I discovered a solution.  While launching the program, going in to the task manager and killing any "COM surrogate" processes before the Localizer finishes loading allows the program to function correctly. 
 
While I am not the most tech savvy person out there, I have been able to reproduce this situation multiple times on my surface 3 LTE.  It appears that the 'COM surrogate" processes are interfering with the startup of the Localizer GUI.  I will be creating a support ticket to explain this and another separate issue I am having with the GUI program.  Hopefully the developers can make use of this information to fix the problem.
 
In addition to this information, It should be noted that only the Microsoft Surface 2 and Surface 3 cellular models have on board GNSS sensors at this time.
0
Franz Replied
September 12, 2016 at 3:34 AM
Same Problem here: Surface 3 LTE, fresh installation of Win 10 ==> Localizer GUI ist not working
The "COM surrogate" trick didn't help me either!
Please help!
0
Joachim Replied
September 16, 2016 at 4:19 AM
I'm running Windows 10 on a Samsung TabPro S. Same problem with the GUI version. I had it running ok with the non-GUI version prior. No response from the support team. Given that this problem exists for so long it seems they can't fix the problem. Probably best to switch to the non-GUI version or look for another product. 
0
Diego Replied
June 30 at 3:09 AM
Has anyone found a solution to this problem "Cannot set allocations" on Windows 10 tablet ?
 

Reply to Thread