1
autostart centrafuse in windows 10
Problem reported by Cornelis - June 10, 2016 at 6:56 PM
Submitted
Hi I have centrafuse 4.4.7.511 and upgraded from windows home premium 7, 32 bit to windows 10's equivalent. Everything seems to work fine but I cannot get CF autostart to work.
 
I have tried the "Shell:common startup" and "Shell: startup" thing that works for every program I tried except it does not for CF. With this I sawa quick flash of "loading..." only once.
 
I also did the registry entry idea as what was on the forum when this problem was reported in windows 8. Again without success for CF but other programs I tried and created an auto start up this way started up OK.
 
Any ideas are most welcome.
 
Thanks
 
Cornelis

5 Replies

Reply to Thread
0
Louk Replied
June 11, 2016 at 3:17 AM
My first guess would be that you can't auto start a program that needs Administrator rights; try to reset this flag in the executable. However when you do this, you also need to apply write access to all the data folders it uses for the user that executes the image (Centrafuse.exe). Normally this will be the account that you use to login, most probably your own name.
 
The folders (and all it's sub-folders) that need write access, next to read access, are:
  • C:\ProgramData\Centrafuse\Centrafuse Auto\...
  • C:\Program Files\Centrafuse\Centrafuse Auto\Plugins\... (64 bit OS only)
  • C:\ProgramFiles (X86)\Centrafuse\Centrafuse Auto\Plugins\... (32 bit OS only)
In the specs above, it is assumed that you boot your system from drive C: and you installed Centrafuse on it's default location.
Have fun,
Louk.
0
Cornelis Replied
June 18, 2016 at 6:25 AM
Hi Louk
 
thanks for your reply. It would seem to be all to do with permissions.
 
In the mean time I swung back to windows 7 as I found compatibility issues with Garmin and the digital tuner/realtek drivers. The thing what pushed me away from windows 7 was the safemode boot up and I found a command that will always boot up windows in normal mode and that seems fine. I can pull the plug any time in the middle of boot up and "she starts normally".
 
I did come across a bluetooth problem but I will have alook first on the forum to see if there is a discussion or thread about this.
 
cheers
 
Cornelis
0
Shad Replied
June 22, 2016 at 7:31 PM
The only way I could get Centrafuse to start when Windows 10 boots was go into the registry and disable user account controls.  This option was not available in home version only pro version of Windows 10.  I tried other programs and anything that did not need administrative rights would boot with Windows.  It seamed Windows blocked anything with administrative right from auto starting on boot up.  Doing this disabled Edge web browser, it pops up message saying user account controls need to be turned on.  There may be a better way, but this was the only thing I could make work.
0
Louk Replied
June 23, 2016 at 12:38 PM
I personally have doubts about any version of Windows that wouldn't have an option to disable UAC. However I'm not able to check this for you, because I don't have a home version of Windows 10, but I did disabled it on my home version of Windows 7 a long time ago. Maybe someone else (that owns a home version of Windows 10) can clear this up.
 
Actually, personally, I wouldn't advice to disable UAC and / or run Centrafuse as administrator, because of the extra security risks you create with this.   However, it seems to be the only way with this version. Currently I'm searching for a solution for this and want to be able to run the next version as a normal user application.
 
Have fun,
Louk.
1
Barry Replied
October 10, 2016 at 12:41 PM
Shad
 
not sure if this too late, but I got it to work.
 
You need to write a batch file (you can use notepad, I saved it as centrastart.bat on my desktop). The batch file looks like this:
 
@echo off
cd "C:\Users\...\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup"
start centrastart (leave off the .lnk or it won't work)
 
from there goto
Windows key+R
in run type
shell:Common Startup (you can leave off "Common" if you want it to start in just the                                         current login. Common loads everytime windows boots)
From there, right click the batch file from the desktop and drop it in the startup window. It will tell you, you have to have admin rights, just click continue and it saves it.
 
Everytime windows boots CF starts, it is a little slow loading, faster if you just click the CF icon, but it does load each time. I guess windows is loading other stuff until it gets to the batch file.
 
Hope this helps.
 
Barry
 
Barry

Reply to Thread