What are the system requirements for Localizer?

Localizer
Localizer requires:

Windows 8.1 Standard or Pro, Window 7 all versions. (Not compatible with Windows 8.1 RT)

.Net Framework 4.5.1

Add Feedback